Long Eaton & Sawley Archive

Long Eaton Present collection 1
Next


A modern day view of Bridge Mills from the canal side. Built by Francis Perks and Sons, it is a three storey tenement factory still in use today.


The Long Eaton Militaires marching through the streets of Long Eaton at Carnival time.


Standing on the corner of the Market Place/High Street, The Famous Corner Pin public house has always been a popular venue for local people.


A canal towpath view of the rear of the Harrington and West End Mills on Leopold Street.


The busy Long Eaton Green. Photograph taken at the height of summer, showing the beautiful flower beds and hanging baskets that adorn the traffic islands.


Taken from the now paved Market Place, looking towards The Green on a summer's day. To the left with the green sun blinds, stands Welch's Florist shop which has been in the town for many years now.


St Laurence's Church and the War Memorial in the Market Place. A restful place for people to sit and reflect.


The Blue Bell Inn on the High Street. One of the oldest standing buildings in the town. An oasis for weary shoppers during hot summer days.


The bowling green on West Park. One of the many leisurely pursuits that is available to people on this beautifully maintained park.


One of the more modern buildings that belongs to Erewash Borough Council and stands in The Green next to the Town Hall.


Probably one of the most recognisable buildings in Long Eaton. Opened in 1906, the library has moved with progress and now has lots of computers where people can connect to the world wide web.


A fairly new addition to the grounds of the library is the sensory garden. Created in 2002 for both able bodied and disabled people to enjoy. The blocks of flats on the centre right are situated on Broad Street.


The currently derelict Silverline Bingo Hall, formerly the Scala Cinema on Derby Road. This building will soon be renovated and re-opened as a multiplex cinema and entertainment centre.


© Copyright 2002 The Long Eaton & Sawley Archive

For more downloads in this series, please visit our web site.

Back